Description
Jooby is a web framework for Java and Kotlin. The pac4j io.jooby.internal.pac4j.SessionStoreImpl#get module deserializes untrusted data. This vulnerability is fixed in 2.17.0 (2.x) and 3.7.0 (3.x).
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
jooby-project jooby
>= 3.0.0.M1, < 3.7.0affected< 2.17.0affected
References
- https://github.com/jooby-project/jooby/security/advisories/GHSA-7c5v-895v-w4q5 ↗
- https://github.com/jooby-project/jooby/commit/3e13562cf36d7407813eae464e0f4b598de15692 ↗
- https://github.com/jooby-project/jooby/blob/v2.x/modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java#L39-L45 ↗
- https://github.com/jooby-project/jooby/blob/v3.6.1/modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java#L77-L84 ↗