Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2025-29927

Authorization Bypass in Next.js Middleware

Description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

vercel next.js

  • >= 11.1.4, < 12.3.5affected
  • >= 14.0.0, < 14.2.25affected
  • >= 15.0.0, < 15.2.3affected
  • >= 13.0.0, < 13.5.9affected

References