Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2025-27821

HDFS native client: Out of bounds write in URI parser of native HDFS client

Description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation HDFS native client

Default version status: unaffected

  • 3.2.0 to < 3.4.2affected

References