Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2025-24854

Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Image plugin

Description

A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache JSPWiki

Default version status: unaffected

  • 0 to ≤ 2.12.2affected

References