Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-24853

Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Header Link processing

Description

A carefully crafted request when creating a header link using the wiki markup syntax, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Further research by the JSPWiki team showed that the markdown parser allowed this kind of attack too. Apache JSPWiki users should upgrade to 2.12.3 or later.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache JSPWiki

Default version status: unaffected

  • 0 to ≤ 2.12.2affected

References