Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2025-23015

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Cassandra

Default version status: unaffected

  • 3.0.0 to ≤ 3.0.30affected
  • 3.1.0 to ≤ 3.11.17affected
  • 4.0.0 to ≤ 4.0.15affected
  • 4.1.0 to ≤ 4.1.7affected
  • 5.0.0 to ≤ 5.0.2affected

References