Skip to content
CVE PROGRAM SOURCE RECORD6.3 Medium

CVE-2025-21617

Guzzle OAuth Subscriber has insufficient nonce entropy

Description

Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

guzzle oauth-subscriber

  • < 0.8.1affected

References