Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-21614

go-git clients vulnerable to DoS via maliciously crafted Git server replies

Description

go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

go-git go-git

  • >= 4.0.0, < 5.13.0affected

References