Description
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Automattic WooCommerce
Default version status: unaffected
8.1.0 to < 8.1.3affected8.2.0 to < 8.2.4affected8.3.0 to < 8.3.3affected8.4.0 to < 8.4.2affected8.5.0 to < 8.5.4affected8.6.0 to < 8.6.3affected8.7.0 to < 8.7.2affected8.8.0 to < 8.8.6affected8.9.0 to < 8.9.4affected9.0.0 to < 9.0.3affected9.1.0 to < 9.1.5affected9.2.0 to < 9.2.4affected9.3.0 to < 9.3.5affected9.4.0 to < 9.4.4affected9.5.0 to < 9.5.3affected9.6.0 to < 9.6.3affected9.7.0 to < 9.7.2affected9.8.0 to < 9.8.6affected9.9.0 to < 9.9.6affected10.0.0 to < 10.0.5affected10.1.0 to < 10.1.3affected10.2.0 to < 10.2.3affected10.3.0 to < 10.3.7affected10.4.0 to < 10.4.3affected