Description
A weakness has been identified in Portabilis i-Educar up to 2.10. Affected by this vulnerability is an unknown functionality of the file /intranet/educar_usuario_cad.php of the component Editar usuário Page. This manipulation of the argument email/data_inicial/data_expiracao causes cross site scripting. It is possible to initiate the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.12 addresses this issue. Patch name: 5b11c0376fcef7ada4c90760b0ca1ed2f16c4de9. You should upgrade the affected component.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Portabilis i-Educar
2.0affected2.1affected2.2affected2.3affected2.4affected2.5affected2.6affected2.7affected2.8affected2.9affected2.10affected2.12unaffected
References
- https://vuldb.com/vuln/323060 ↗
- https://vuldb.com/vuln/323060/cti ↗
- https://vuldb.com/cve/CVE-2025-10099 ↗
- https://vuldb.com/submit/644967 ↗
- https://github.com/marcelomulder/CVE/blob/main/i-educar/CVE-2025-10099.md ↗
- https://github.com/marcelomulder/CVE/blob/main/i-educar/Cross-Site%20Scripting%20(XSS)%20Reflected%20endpoint%20%60educar_usuario_cad.php%60%20parameters%20%60email%60,%20%60data_inicial%60,%20%60data_expiracao%60.md ↗
- https://github.com/portabilis/i-educar/commit/5b11c0376fcef7ada4c90760b0ca1ed2f16c4de9 ↗
- https://github.com/portabilis/i-educar/tree/2.12 ↗
- https://github.com/portabilis/i-educar/ ↗