Skip to content
CVE PROGRAM SOURCE RECORD8.7 High

CVE-2024-8810

Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed GitHub Apps to grant themselves write access

Description

A GitHub App installed in organizations could upgrade some permissions from read to write access without approval from an organization administrator. An attacker would require an account with administrator access to install a malicious GitHub App. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.14.1, 3.13.4, 3.12.9, 3.11.15, and 3.10.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GitHub Enterprise Server

Default version status: affected

  • 3.10.0 to ≤ 3.10.16affected
  • 3.11.0 to ≤ 3.11.14affected
  • 3.12.0 to ≤ 3.12.8affected
  • 3.13.0 to ≤ 3.13.3affected
  • 3.14 to ≤ 3.14.0affected

References