Skip to content
CVE PROGRAM SOURCE RECORD6.4 Medium

CVE-2024-5945

WP SVG Images <= 4.3 - Authenticated (Author+) Stored Cross-Site Scripting via SVG

Description

The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

shortpixel WP SVG Images

Default version status: unaffected

  • 0 to ≤ 4.3affected

References