Skip to content
CVE PROGRAM SOURCE RECORD5.9 Medium

CVE-2024-5817

Improper authorization allows read access to issue content in GitHub Enterprise Server

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed read access to issue content via GitHub Projects. This was only exploitable in internal repositories and required the attacker to have access to the corresponding project board. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GitHub GitHub Enterprise Server

Default version status: affected

  • 3.10.0 to ≤ 3.10.13affected
  • 3.11.0 to ≤ 3.11.11affected
  • 3.12.0 to ≤ 3.12.5affected
  • 3.13 to ≤ 3.13.0affected
  • 3.9.0 to ≤ 3.9.16affected

References