Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2024-5816

Improper authorization allows persistent access in GitHub Enterprise Server

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a suspended GitHub App to retain access to the repository via a scoped user access token. This was only exploitable in public repositories while private repositories were not impacted. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.9.17, 3.10.14, 3.11.12, 3.12.6, 3.13.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GitHub GitHub Enterprise Server

Default version status: affected

  • 3.10.0 to ≤ 3.10.13affected
  • 3.11.0 to ≤ 3.11.11affected
  • 3.12.0 to ≤ 3.12.5affected
  • 3.13 to ≤ 3.13.0affected
  • 3.9.0 to ≤ 3.9.16affected

References