Skip to content
CVE PROGRAM SOURCE RECORD9.4 Critical

CVE-2024-56333

Remote code execution in onyxia-api

Description

Onyxia is a web app that aims at being the glue between multiple open source backend technologies to provide a state of art working environment for data scientists. This critical vulnerability allows authenticated users to remotely execute code within the Onyxia-API, leading to potential consequences such as unauthorized access to other user environments and denial of service attacks. This issue has been patched in api versions 4.2.0, 3.1.1, and 2.8.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

InseeFrLab onyxia

  • < 2.8.2affected
  • >= 3.0.0, < 3.1.1affected
  • >= 4.0.0, < 4.2.0affected

References