Description
An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
GitHub GitHub Enterprise Server
Default version status: affected
3.9.0 to ≤ 3.9.16affected3.10.0 to ≤ 3.10.13affected3.11.0 to ≤ 3.11.11affected3.12.0 to ≤ 3.12.5affected3.13 to ≤ 3.13.0affected
References
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.17 ↗
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.14 ↗
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.10 ↗
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.6 ↗
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.1 ↗