Skip to content
CVE PROGRAM SOURCE RECORD7.6 High

CVE-2024-53949

Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled

Description

Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.  issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Superset

Default version status: unaffected

  • 2.0.0 to < 4.1.0affected

References