Skip to content
CVE PROGRAM SOURCE RECORD5.1 Medium

CVE-2024-53847

Trix vulnerable to Cross-site Scripting on copy & paste

Description

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

basecamp trix

  • >= 2.0.0, < 2.1.9affected
  • >= 1.0.0, < 1.3.3affected

References