Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2024-5131

Improper Access Control in lunary-ai/lunary

Description

An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

lunary-ai lunary-ai/lunary

  • unspecified to < 1.2.25affected

References