Skip to content
CVE PROGRAM SOURCE RECORD7.6 High

CVE-2024-5126

Improper Access Control in lunary-ai/lunary

Description

An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

lunary-ai lunary-ai/lunary

  • unspecified to < 1.2.25affected

References