Skip to content
CVE PROGRAM SOURCE RECORD2.6 Low

CVE-2024-45719

Apache Answer: Predictable Authorization Token Using UUIDv1

Description

Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Answer

Default version status: unaffected

  • 0 to ≤ 1.4.0affected

References