Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2024-45605

Improper authorization on deletion of user issue alert notifications in sentry

Description

Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

getsentry sentry

  • >=23.9.0, < 24.9.0affected

References