Skip to content
CVE PROGRAM SOURCE RECORD4.8 Medium

CVE-2024-45478

Apache Ranger: Stored XSS in Edit Service page - Add logic to validate user input

Description

Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Ranger

Default version status: unaffected

  • 2.4.0 to < 2.5.0affected

References