Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2024-43115

Apache DolphinScheduler: Alert Script Attack

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache DolphinScheduler

Default version status: unaffected

  • 0 to < 3.2.2affected

References