Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2024-39877

Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler

Description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Airflow

Default version status: unaffected

  • 2.4.0 to < 2.9.3affected

References