Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2024-39320

Discourse allows iframe injection though default site setting

Description

Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • < 3.2.5affected
  • >= 3.3.0.beta1, < 3.3.0.beta5affected

References