Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2024-38357

TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements

Description

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

tinymce tinymce

  • < 5.11.0affected
  • >= 6.0.0, <6.8.4affected
  • >= 7.0.0, < 7.2.0affected

References