Skip to content
CVE PROGRAM SOURCE RECORD8.6 High

CVE-2024-38286

Apache Tomcat: Denial of Service

Description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.0-M20affected
  • 10.1.0-M1 to ≤ 10.1.24affected
  • 9.0.13 to ≤ 9.0.89affected
  • 8.5.35 to ≤ 8.5.100affected
  • 7.0.92 to ≤ 7.0.109affected
  • 10.0.0-M1 to ≤ 10.0.27unknown

References