Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2024-3761

Missing Authorization on Delete Datasets in lunary-ai/lunary

Description

In lunary-ai/lunary version 1.2.2, the DELETE endpoint located at `packages/backend/src/api/v1/datasets` is vulnerable to unauthorized dataset deletion due to missing authorization and authentication mechanisms. This vulnerability allows any user, even those without a valid token, to delete a dataset by sending a DELETE request to the endpoint. The issue was fixed in version 1.2.8. The impact of this vulnerability is significant as it permits unauthorized users to delete datasets, potentially leading to data loss or disruption of service.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

lunary-ai lunary-ai/lunary

  • unspecified to < 1.2.8affected

References