Skip to content
CVE PROGRAM SOURCE RECORD6.3 Medium

CVE-2024-37165

Discourse has an XSS via Onebox system

Description

Discourse is an open source discussion platform. Prior to 3.2.3 and 3.3.0.beta3, improperly sanitized Onebox data could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. This vulnerability is fixed in 3.2.3 and 3.3.0.beta3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • < 3.2.3affected
  • >= 3.3.0.beta1, < 3.3.0.beta3affected

References