Skip to content
CVE PROGRAM SOURCE RECORD6.8 Medium

CVE-2024-35164

Apache Guacamole: Improper input validation of console codes

Description

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Guacamole

Default version status: unaffected

  • 0.8.0 to ≤ 1.5.5affected

References