Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2024-3204

c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow

Description

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

n/a c-blosc2

  • 2.13.0affected
  • 2.13.1affected
  • 2.13.2affected

References