Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2024-3203

c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow

Description

A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

n/a c-blosc2

  • 2.13.0affected
  • 2.13.1affected
  • 2.13.2affected

References