Description
Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
git git
= 2.45.0affected= 2.44.0affected>= 2.43.0, < 2.43.4affected>= 2.42.0, < 2.42.2affected= 2.41.0affected>= 2.40.0, < 2.40.2affected< 2.39.4affected
References
- https://github.com/git/git/security/advisories/GHSA-xfc6-vwr8-r389 ↗
- https://github.com/git/git/commit/f4aa8c8bb11dae6e769cd930565173808cbb69c8 ↗
- https://git-scm.com/docs/git-clone ↗
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/ ↗
- http://www.openwall.com/lists/oss-security/2024/05/14/2 ↗
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html ↗
- https://lists.debian.org/debian-lts-announce/2024/09/msg00009.html ↗