Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2024-31866

Apache Zeppelin: Interpreter download command does not escape malicious code injection

Description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Zeppelin

Default version status: unaffected

  • 0.8.2 to < 0.11.1affected

References