Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2024-31865

Apache Zeppelin: Cron arbitrary user impersonation with improper privileges

Description

Improper Input Validation vulnerability in Apache Zeppelin. The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Zeppelin

Default version status: unaffected

  • 0.8.2 to < 0.11.1affected

References