Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2024-31860

Apache Zeppelin: Path traversal vulnerability

Description

Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access.  This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Zeppelin

Default version status: unaffected

  • 0.9.0 to < 0.11.0affected

References