Skip to content
CVE PROGRAM SOURCE RECORD8.1 High

CVE-2024-31452

OpenFGA Authorization Bypass

Description

OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

openfga openfga

  • >= 1.5.0, < 1.5.3affected

References