Skip to content
CVE PROGRAM SOURCE RECORD6.4 Medium

CVE-2024-28098

Apache Pulsar: Improper Authorization For Topic-Level Policy Management

Description

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Pulsar

Default version status: unaffected

  • 2.7.1 to < 2.10.6affected
  • 2.11.0 to < 2.11.4affected
  • 3.0.0 to < 3.0.3affected
  • 3.1.0 to < 3.1.3affected
  • 3.2.0 to < 3.2.1affected

References