Skip to content
CVE PROGRAM SOURCE RECORD10.0 Critical

CVE-2024-27298

Parse Server literalizeRegexPart SQL Injection

Description

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

parse-community parse-server

  • < 6.5.0affected
  • >= 7.0.0-alpha.1, < 7.0.0-alpha.20affected

References