Skip to content
CVE PROGRAM SOURCE RECORD8.5 High

CVE-2024-27135

Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution

Description

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Pulsar

Default version status: unaffected

  • 2.4.0 to < 2.10.6affected
  • 2.11.0 to < 2.11.4affected
  • 3.0.0 to < 3.0.3affected
  • 3.1.0 to < 3.1.3affected
  • 3.2.0 to < 3.2.1affected

References