Skip to content
CVE PROGRAM SOURCE RECORD4.3 Medium

CVE-2024-26016

Apache Superset: Improper authorization validation on dashboards and charts import

Description

A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Superset

Default version status: unaffected

  • 0 to < 3.0.4affected
  • 3.1.0 to < 3.1.1affected

References