Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2024-25621

containerd affected by a local privilege escalation via wide permissions on CRI directory

Description

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

containerd containerd

  • < 1.7.29affected
  • >= 2.0.0-beta.0, < 2.0.7affected
  • >= 2.1.0-beta.0, < 2.1.5affected
  • >= 2.2.0-beta.0, < 2.2.0affected

References