Skip to content
CVE PROGRAM SOURCE RECORD4.9 Medium

CVE-2024-24773

Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

Description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Superset

Default version status: unaffected

  • 0 to < 3.0.4affected
  • 3.1.0 to < 3.1.1affected

References