Skip to content
CVE PROGRAM SOURCE RECORD4.3 Medium

CVE-2024-24772

Apache Superset: Improper Neutralisation of custom SQL on embedded context

Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Superset

Default version status: unaffected

  • 0 to < 3.0.4affected
  • 3.1.0 to < 3.1.1affected

References