Skip to content
CVE PROGRAM SOURCE RECORD6.3 Medium

CVE-2024-23834

Discourse improperly sanitized user input leads to XSS

Description

Discourse is an open-source discussion platform. Improperly sanitized user input could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. The vulnerability is patched in 3.1.5 and 3.2.0.beta5. As a workaround, ensure Content Security Policy is enabled and does not include `unsafe-inline`.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • < 3.1.5affected
  • >= 3.2.0.beta1, < 3.2.0.beta5affected

References