Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2024-22399

Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server

Description

Deserialization of Untrusted Data vulnerability in Apache Seata.  When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol. This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0. Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Seata

Default version status: unaffected

  • 2.0.0affected
  • 1.0.0 to ≤ 1.8.0affected

References