Skip to content
CVE PROGRAM SOURCE RECORD7.8 High

CVE-2024-22369

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Description

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Camel

Default version status: unaffected

  • 3.0.0 to < 3.21.4affected
  • 3.22.0 to < 3.22.1affected
  • 4.0.0 to < 4.0.4affected
  • 4.1.0 to < 4.4.0affected

References