Skip to content
CVE PROGRAM SOURCE RECORD9.7 Critical

CVE-2024-22212

Nextcloud global site selector authentication bypass

Description

Nextcloud Global Site Selector is a tool which allows you to run multiple small Nextcloud instances and redirect users to the right server. A problem in the password verification method allows an attacker to authenticate as another user. It is recommended that the Nextcloud Global Site Selector is upgraded to version 1.4.1, 2.1.2, 2.3.4 or 2.4.5. There are no known workarounds for this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

nextcloud security-advisories

  • >= 1.1.0, < 1.4.1affected
  • >= 2.0.0, < 2.1.2affected
  • >= 2.2.0, < 2.3.4affected
  • >= 2.4.0, < 2.4.5affected

References