Skip to content
CVE PROGRAM SOURCE RECORD3.3 Low

CVE-2024-2213

Improper Authentication in zenml-io/zenml

Description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

zenml-io zenml-io/zenml

  • unspecified to < 0.56.3affected

References